wmjy.net
当前位置:首页 >> org.slF4j.impl mAvEn >>

org.slF4j.impl mAvEn

少个包 org.slf4j slf4j-log4j12 1.7.5 把这个放到pom.xml依赖中就可以了

中文改成英文

应该是jar包版本不一致! 比如说你的框架需要的版本是1.5的,而你提供的版本是1.2的,造成了参数的个数或者类型不一致!就会报这个错误的!

1先创建一个基于maven的项目,点击打开pom.xml文件 2 点击Dependencies标签页,然后点击Dependencies中的add按钮,输入我们想添加的jar包名字,就会出现下图中所示,它会把对应名称的所有版本jar包列出来 3 点击OK之后,在pom.xml会带回jar包的...

检查jar包是否存在冲突或jar版本是存在不兼容的问题,我的项目中是因为slf4j-api-1.6.2.jar和slf4j-jdk14-1.5.6.jar不兼容问题,将slf4j-jdk14-1.5.6.jar删除,下一个slf4j-jdk14-1.6.2.jar放在lib目录下,问题解决。

错误显示你的slf4j的包版本有点老,它需要1.6版本的,你的接口貌似是1.5.8版本的

Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory很明显 少了JAR包啊

slf4j只是提供一个接口,需要绑定一个实现,你的build path里加进3个实现(nop log4j, jdk),而且其中log4j还需要log4j-x.y.z.jar。

collection.find().toArray(function(err,docs){ console.log(docs); //将数据显示到网页上 // console.log('1'+docs[0].name); // $('#question').append(''+docs+''); // document.getElementById("editLevels").value =docs;

版本冲突 http://blog.csdn.net/rommal7090/archive/2009/04/01/4041240.aspx

网站首页 | 网站地图
All rights reserved Powered by www.wmjy.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com